Technical Issue
Incident Report for Foleon
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 14:01 CEST
Investigating
The Foleon platform is currently experiencing technical difficulties. The Development team is working to resolve the issue.
Posted Sep 30, 2024 - 13:55 CEST
This incident affected: Platform.